MyPrintCenter and email printing slowness
Incident Report for Wharton Computing
Resolved
This issue has been resolved, and printing is working as expected.
Posted Feb 12, 2024 - 08:58 EST
Investigating
We are investigating an issue with printing that is impacting many jobs submitted via MyPrintCenter or email. These jobs are timing out and not printing. Our team is in contact with our printing vendor, and we will share updates when available.
Posted Feb 08, 2024 - 21:18 EST
This incident affected: Student Printing.