CampusGroups Calendar Syncing
Incident Report for Wharton Computing
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 11:24 EST
Update
CampusGroups has resolved the issue. If you encounter any trouble scheduling appointments through CampusGroups please reach out to Student Support: support@wharton.upenn.edu.
Posted Feb 22, 2024 - 11:24 EST
Investigating
CampusGroups is currently having an issue with calendar sync as a result appointment booking is unavailable. CampusGroups is looking into the matter.
Posted Feb 15, 2024 - 13:44 EST
This incident affected: Web (CampusGroups).