Mailing List App Offline
Incident Report for Wharton Computing
Resolved
The issue has been resolved and the Mailing List admin application is fully functional.
Posted Aug 08, 2023 - 13:39 EDT
Investigating
The application for managing Wharton Mailing Lists is currently unavailable as we troubleshoot an issue.

Emails sent to Wharton Email Lists will be delivered as usual, as the mailing lists themselves are fully functional.

If you need to update the settings/membership of a mailing list, please email apps-support@wharton.upenn.edu with the list name and the needed change.
Posted Aug 08, 2023 - 09:26 EDT
This incident affected: Web (Wharton Mailing Lists).