Delays When Changing or Creating Email Forwarding
Incident Report for Wharton Computing
Resolved
This incident has been resolved.
Posted May 04, 2023 - 07:31 EDT
Monitoring
This issue was resolved around 5pm today and ISC is continuing to monitor. Please contact your Wharton Computing representative (https://support.wharton.upenn.edu/help/computing-contact-list) with any questions.
Posted May 03, 2023 - 18:44 EDT
Identified
The issue with mailbox creation and mail forwarding is ongoing, and Penn's ISC Email team is working to resolve it as soon as possible. Until then, any updates to your email forwarding, as well as any new email accounts created, will not complete the final step and will not be available.

Once the fix is in place, we expect all the changes made since the beginning of the issue to take effect.

We'll update this post as we learn more. Please contact your Wharton Computing representative (https://support.wharton.upenn.edu/help/computing-contact-list) with any questions.
Posted May 03, 2023 - 18:05 EDT
Investigating
Beginning this morning around 11:00 AM Penn's ISC Email team noticed that changes made to email forwarding were not taking effect immediately. This also affects anyone creating a new email account with the University.

We'll post updates here as we learn more.
Posted May 03, 2023 - 15:44 EDT
This incident affected: PennO365 (PennO365 (Faculty/Staff Email)) and GSuite (Student Email).