Storage Issue Impacting Several Systems
Incident Report for Wharton Computing
Resolved
ISC has resolved the issue.
Posted Jul 24, 2024 - 15:49 EDT
Monitoring
ISC has fixed the storage issue. They are working on validating systems and expect the issue to be fully resolved in 1 - 2 hours.

ISC will post updates here: https://status.isc.upenn.edu/incidents/622256
Posted Jul 24, 2024 - 14:50 EDT
Update
ISC continues to troubleshoot the issue.
Posted Jul 24, 2024 - 12:52 EDT
Investigating
Several systems are currently down due to a storage issue. ISC, the University's central IT group, is working on the issue and will post updates here: https://status.isc.upenn.edu/incidents/622256
Posted Jul 24, 2024 - 11:29 EDT
This incident affected: High Performance Computing Cluster and Student Printing.