Two-Step Verification Slowness
Incident Report for Wharton Computing
Resolved
This issue has been resolved.
Posted Aug 21, 2023 - 20:20 EDT
Investigating
Penn is aware of an issue with Two-Step Verification being slow or not working.

This is a widespread issue with our vendor, Duo, and is currently being investigated. You can find more information here: https://status.duo.com.
Posted Aug 21, 2023 - 10:02 EDT
This incident affected: Web (PennKey Logins).