PennNet Connectivity Issues

Incident Report for Wharton Computing

Resolved

ISC has resolved the issue. More information can be found here: https://status.isc.upenn.edu/incidents/714142
Posted Sep 11, 2025 - 16:26 EDT

Investigating

Both wired and wireless networking on Campus are experiencing intermittent outages. We're working with Penn's centeral IT group (ISC) to correct the issue.
Posted Sep 11, 2025 - 14:41 EDT
This incident affected: Wharton Building Networks (Huntsman Hall Network, Steinberg Hall-Dietrich Hall Network, Vance Hall Network, Lauder Institute Network, Steinberg Conference Center Network, 2401 Walnut Street Network, CPC Network, St. Leonard's Court Network) and AirPennNet.