Student Printing Offline
Incident Report for Wharton Computing
Resolved
All printing services are back online.
Posted Aug 30, 2023 - 16:30 EDT
Investigating
Printing is currently offline. We are actively working on a solution.
Posted Aug 30, 2023 - 10:39 EDT
This incident affected: Student Printing.