Penn Box Login, Uploads, Download Issues
Incident Report for Wharton Computing
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 15:54 EST
Monitoring
Box has identified and corrected the issue. Their services are slowly recovering. Visit: https://status.box.com for more details.
Posted Dec 15, 2023 - 13:51 EST
Identified
There are issues with logging into Penn Box as well as downloading and uploading files. Box is aware of the issue, and is working on a solution. You can follow along on their status page: https://status.box.com
Posted Dec 15, 2023 - 10:08 EST
This incident affected: PennBox (Box Sync, Box Website).