Mailbox Access issues for PennO365

Incident Report for Wharton Computing

Resolved

Microsoft has resolved this issue.
Posted Jul 14, 2025 - 14:17 EDT

Investigating

Microsoft is investigating a widespread issue with O365 which is impacting PennO365. Currently people may not be able to access their PennO365 mailboxes and email may be delayed.

Updates will be provided as Microsoft continues working on this issue.
Posted Jul 14, 2025 - 11:02 EDT
This incident affected: PennO365 (PennO365 (Faculty/Staff Email)).