VPN Connection Issues
Incident Report for Wharton Computing
Resolved
We identified the root cause to be an offline service related to the extensive network outage earlier this week. We are working with ISC, Penn’s central IT group, to increase redundancy around these services going forward.
Posted Feb 22, 2024 - 09:43 EST
Identified
A rollover to our backup VPN appliance did not correct the issue. We continue to work with our VPN vendor to address the issues that continue to impact the Wharton VPN.
Posted Feb 21, 2024 - 13:01 EST
Update
Our team is working with ISC and our VPN vendor to identify and correct the connection issue.

If you are on campus and experiencing an issue connecting with the Wharton VPN use a wired connection or a public computer to access resources that require the VPN.
Posted Feb 21, 2024 - 09:30 EST
Investigating
Some people are reporting issuing with connecting using the Wharton VPN (FortiClient). Our team is working with ISC to address the issue.
Posted Feb 20, 2024 - 14:50 EST
This incident affected: VPN (Staff & Faculty).