Major Windows Outage
Incident Report for Wharton Computing
Resolved
All services are fully operational, including classroom, public computers, and GSRs.

Individual computers may still be encountering the issue. Please see this article for more details about addressing it on your Wharton computer: https://support.wharton.upenn.edu/help/crowdstrike-bluescreen
Posted Jul 19, 2024 - 19:45 EDT
Update
Our team continues to work on bringing Windows computers back online. Most services are back up an fully operational.

Classroom, public computers, and GSRs should all be available by the end of the day.

Please see this article for more details about addressing this issue on your Wharton computer: https://support.wharton.upenn.edu/help/crowdstrike-bluescreen
Posted Jul 19, 2024 - 15:21 EDT
Identified
Wharton Custom Applications are back online, though many other services and computers remain impacted.
Posted Jul 19, 2024 - 10:04 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 07:17 EDT
Investigating
There is currently an issue impacting many Wharton Windows computers (both desktop and server) leading the machines to "blue screen." We are working with our vendor to address the issue, but in the meantime many Wharton staff, faculty, and services are impacted.
Posted Jul 19, 2024 - 07:12 EDT
This incident affected: Labs (F80, F75, 380, 375) and Web (Wharton Custom Applications).