Intermittent Service Disruptions

Incident Report for Wharton Computing

Resolved

Cloudflare and Google have fixed the core issues. Some residual issues may persist for a short time, but most services are back up.
Posted Jun 12, 2025 - 19:26 EDT

Identified

We are currently observing service disruptions potentially related to upstream providers, including Cloudflare and Google Cloud. Our team is actively monitoring the situation and working to mitigate any impact.

Statuses for these providers can be found at the links below.
> https://status.cloud.google.com
> https://www.cloudflarestatus.com
Posted Jun 12, 2025 - 15:59 EDT