AWS Outage affecting multiple services

Incident Report for Wharton Computing

Resolved

Amazon has resolved the AWS issues.
Posted Oct 20, 2025 - 19:30 EDT

Update

Update: AWS and several impacted services are reporting that service recovery is continuing to improve, although access to many services is still not back to normal.

AWS is providing regular updates for its services via the AWS Health Dashboard ( https://health.aws.amazon.com/health/status ), and you can use Downdetector ( https://downdetector.com/ ) to check on updates for other affected services.
Posted Oct 20, 2025 - 17:52 EDT

Monitoring

Earlier today, Amazon Web Services (AWS) experienced a major service disruption - the issue caused increased error rates and slower performance for several AWS services, and for many other companies' services that rely on AWS.

We are aware of ongoing issues impacting the following services:

Atlassian services, including Jira and Confluence
Smartsheet
Canvas
Panopto
Posted Oct 20, 2025 - 10:10 EDT
This incident affected: AWS.