Access Issues with Microsoft 365
Incident Report for Wharton Computing
Resolved
Microsoft reports the issue has been resolved via their Twitter account: https://twitter.com/MSFT365Status
Posted Jun 05, 2023 - 13:49 EDT
Investigating
There are many reports of trouble accessing Microsoft 365's Outlook Web version and the Client version from campus users. Microsoft is looking into the problem, and is posting updates on Twitter: https://twitter.com/MSFT365Status
Posted Jun 05, 2023 - 11:29 EDT
This incident affected: PennO365 (PennO365 (Faculty/Staff Email)).