Gmail Delivery Delays
Incident Report for Wharton Computing
Resolved
Over the last few days the mail delay issues seem to have resolved. We are actively monitoring the situation and will post updates if appropriate.
Posted Mar 10, 2021 - 10:26 EST
Investigating
Google is delaying the delivery of some UPenn emails sent to Gmail users. This impacts messages sent from UPenn directly to Gmail and forwarded messages. ISC is currently working with Google to resolve this issue.

Impacted messages are delayed, but will be delivered.
Posted Mar 03, 2021 - 09:14 EST
This incident affected: GSuite (Student Email).