Canvas performance issues related to AWS Outage

Incident Report for Wharton Computing

Resolved

Canvas is now accessible.
Posted Oct 20, 2025 - 19:29 EDT

Update

Canvas continues to be inaccessible for all US customers. The University's Canvas team is monitoring the issue and will post updates: https://infocanvas.upenn.edu/2025/10/20/continuing-outage-canvas-10-20-25/
Posted Oct 20, 2025 - 17:47 EDT

Monitoring

Canvas is experiencing issues and degraded performance due to an ongoing AWS incident.
As of 9:40 EST, Canvas' official status is "Down for Maintenance" See https://status.instructure.com/ for more details.

Canvas and Class Recordings access issues related to AWS Outage; available course information alternatives
Canvas, including course-related access to the University's Class Recordings (Panopto) infrastructure, remains unavailable due to an ongoing AWS incident. Here are some possible workarounds while suppliers work to fix issues:

> Classroom locations and basic course information can be found either at https://courses.upenn.edu (for all users), or https://path.at.upenn.edu/ (enrolled students only)

> Students needing to contact their professor can search Penn Directory for contact information or Syllabi@Wharton for a preliminary course syllabus.

> Wharton faculty needing to contact their students may access Instruction Center to use the Classlists tool.
Posted Oct 20, 2025 - 10:29 EDT
This incident affected: Learning Tools (Canvas).