AWS Service Disruption (11/25)
Incident Report for Wharton Computing
Resolved
Amazon has resolved this outage. More details can be found here: https://status.aws.amazon.com/
Posted Nov 26, 2020 - 11:37 EST
Investigating
AWS is investigating an issue that is causing errors affecting multiple services. This issue is widespread and not specific to Penn. However, the disruption impacts several Penn services, including Penn Device, Covid Results, and PennPath. It's also affecting some services in Canvas.
Posted Nov 25, 2020 - 12:59 EST
This incident affected: AWS.